LotusScript: View-Formel generieren

Spalte A ab Zeile 2: Testfall-Nummern

Zelle B1 enthält:

SELECT (Form = "Testfaelle") & 

Formel in Zelle B2:

=WENN(ZEILE()=2;VERKETTEN(ZEICHEN(40);ZEICHEN(64);"Contains";ZEICHEN(40);"Testfall_Nummer";ZEICHEN(59);" ";ZEICHEN(34);A2;ZEICHEN(34);ZEICHEN(41));VERKETTEN(ZEICHEN(124);" ";ZEICHEN(64);"Contains";ZEICHEN(40);" Testfall_Nummer";ZEICHEN(59);" ";ZEICHEN(34);A2;ZEICHEN(34);WENN(ISTLEER(INDIREKT(ADRESSE(ZEILE()+1;SPALTE();4;1)));ZEICHEN(41)&ZEICHEN(41);ZEICHEN(41))))

Ergebnis in Spalte B: View-Formel zum einfügen in Lotus Notes

SELECT (Form = "Testfaelle") & 
(@Contains(Testfall_Nummer; "7527")
| @Contains( Testfall_Nummer; "3691")
| @Contains( Testfall_Nummer; "1372")
| @Contains( Testfall_Nummer; "7020"))

Hello, World!

public class HelloWorld {
	public static void main(String[] args) {
	// Print "Hello, World!" to Console
		System.out.println("Hello, World!");
	}
}